48-84
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Got the Shovels a-rollin'

Go down

Got the Shovels a-rollin' Empty Got the Shovels a-rollin'

Post  sunnydog on Sat Apr 04, 2015 8:25 am

Another spring has sprung...been doin my best to get the girls oot and aboot...
Took the Econo down to Idaho last weekend...mail run...snapped a belt on the way home...so now I'm waitin on some parts....damn nice ride tho
Got the Shovels a-rollin' 1E6C2F63-3729-47DE-AAFA-8F84C9599110_zpsy3owgzkl

So using the "family bus" for transport to work lately
Got the Shovels a-rollin' 8578FED9-9703-4059-A0FC-6C2A6BB58DF8_zpsesq4dcwf
sunnydog
sunnydog

Posts : 1988
Join date : 2012-10-28
Age : 51
Location : Akimbo Alogo

Back to top Go down

Got the Shovels a-rollin' Empty Re: Got the Shovels a-rollin'

Post  h.d.ryder on Sat Apr 04, 2015 10:33 am

Nice early start Sunny, Too bad about the belt.

h.d.ryder

Posts : 210
Join date : 2012-11-02

Back to top Go down

Got the Shovels a-rollin' Empty Re: Got the Shovels a-rollin'

Post  Dennman on Sat Apr 04, 2015 1:48 pm

Good to hear you've been on a longer ride on the Econo.Any issues w/ the "new" from fender?
And that's why I never run a piece of rubber to drive the Weerier.Nice to have a backup to stay In The Wind!
Just don't be ridin by here until I get insured.Otherwise you'll hear a very loud "BASTARD" yelled from my shop.
Dennman
Dennman

Posts : 1391
Join date : 2012-10-31
Age : 72
Location : Courtenay

Back to top Go down

Got the Shovels a-rollin' Empty Re: Got the Shovels a-rollin'

Post  sunnydog on Sat Apr 04, 2015 2:47 pm

Lol I'd love to run primary chain...just got to figger how to run with tin primary cause hand-shifter won't clear factory primary hump, tensioner issues etc...but I WILL figger it out...if anybody knows proper chain type/length for old style pan or knuck tin primary's I'm all ears....but give me some time I only been ridin this bike twelve years lol!  ...had her dialed last couple years but removing trans for rebuild I need to get belt back to aligned/tensioned right...think in this case I had belt too tight.
As far as how she runs the trans works great, no leaks I've seen yet...rolled along like a champ as the Econo always has for me
sunnydog
sunnydog

Posts : 1988
Join date : 2012-10-28
Age : 51
Location : Akimbo Alogo

Back to top Go down

Got the Shovels a-rollin' Empty Re: Got the Shovels a-rollin'

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum